Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Video REST API connectivity issues
      Incident Report for Twilio
      Resolved
      This incident has been resolved.
      Posted Apr 08, 2020 - 05:44 PDT
      Monitoring
      Our engineering team applied a subsequent fixed and we are observing service recovery. We are continuing to monitor the situation.
      Posted Apr 08, 2020 - 05:35 PDT
      Update
      We are continuing to investigate this issue.
      Posted Apr 08, 2020 - 04:54 PDT
      Investigating
      The issue has resurfaced and our teams are actively working on a fix. We will provide more information as soon as we have an update.
      Posted Apr 08, 2020 - 04:45 PDT
      Monitoring
      Our engineers have implemented a fix, and we’re beginning to see recovery of REST requests to our Programmable Video API
      Posted Apr 08, 2020 - 04:30 PDT
      Update
      We are experiencing degraded performance of the REST requests to our Programmable Video API. Our engineering teams are actively investigating the issue and working on applying a fix. We will provide more information when it becomes available.
      Posted Apr 08, 2020 - 04:07 PDT
      Investigating
      Our monitoring systems have detected a potential issue with Video connectivity. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Apr 08, 2020 - 03:39 PDT
      This incident affected: PROGRAMMABLE VIDEO (Group Rooms, Peer-to-Peer Rooms, Recordings, Compositions, Network Traversal Service).