Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Some incoming calls to U.K. numbers failing
      Incident Report for Twilio
      Resolved
      The service is operating normally at this time.
      Posted Mar 24, 2017 - 02:46 PDT
      Monitoring
      We are seeing a recovery of service for incoming calls in the U.K.
      Posted Mar 24, 2017 - 02:36 PDT
      Investigating
      Incoming calls are failing for some local Twilio numbers in the U.K. We are investigating the issue.
      Posted Mar 24, 2017 - 02:20 PDT
      This incident affected: PROGRAMMABLE VOICE (PSTN) and PHONE NUMBERS.