Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Delays to MTN Network Nigeria
Incident Report for Twilio
Resolved
We are no longer experiencing SMS delivery delays when sending messages to MTN Network Nigeria. This incident has been resolved.
Posted May 29, 2021 - 15:36 PDT
Monitoring
We are observing recovery in SMS delivery delays when sending messages to MTN Network Nigeria. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2hours or as soon as more information becomes available.
Posted May 29, 2021 - 14:38 PDT
Update
We are experiencing SMS delivery delays when sending messages to MTN Network Nigeria. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted May 29, 2021 - 14:18 PDT
Update
We are continuing to investigate this issue.
Posted May 29, 2021 - 14:11 PDT
Update
We are continuing to investigate this issue.
Posted May 29, 2021 - 14:11 PDT
Update
We are continuing to investigate this issue.
Posted May 29, 2021 - 14:08 PDT
Investigating
We've become aware of a potential issue with subset of external customers presenting SMS Delivery Delays to MTN Network Nigeria. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted May 29, 2021 - 14:07 PDT
This incident affected: PROGRAMMABLE MESSAGING (SMS).