The Expense Management Page on Twilio Billing Console is functional. This incident has been resolved.
Posted Sep 18, 2024 - 02:30 PDT
Monitoring
We have been informed that a fix is implemented and the Expense Management Page on Twilio Billing Console is functional. We will continue to monitor to ensure a full recovery. We expect to provide another update in 30 minutes or as soon as more information becomes available.
Posted Sep 18, 2024 - 01:59 PDT
Update
The Expense Management page is currently not accessible to customers on Twilio Billing Console. We have identified a fix and are continuing working on a fix. We will provide a next update in 2 hours or as soon as the next update is available.
Posted Sep 18, 2024 - 01:21 PDT
Identified
The Expense Management page is currently not accessible to customers on Twilio Billing Console. We have identified a fix and are currently rolling out a fix for this.
Posted Sep 18, 2024 - 00:21 PDT
This incident affected: TWILIO PLATFORM (Billing).