Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Zipwhip Gateway
      Issues related to Zipwhip's Software
        Scheduled maintenance
        System Metrics
        MMS Delivery Delays to C-Spire Network in United States of America
        Incident Report for Twilio
        Resolved
        We are no longer experiencing SMS delivery delays when sending messages to C-Spire Network in United States of America. This incident has been resolved.
        Posted Jan 17, 2025 - 03:13 PST
        Monitoring
        We are observing recovery in SMS delivery delays when sending messages to C-Spire Network in United States of America. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
        Posted Jan 17, 2025 - 01:22 PST
        Update
        We are experiencing SMS delivery delays when sending messages to C-Spire Network in United States of America. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 4 hours or as soon as more information becomes available.
        Posted Jan 16, 2025 - 21:27 PST
        Update
        We are experiencing SMS delivery delays when sending messages to C-Spire Network in United States of America. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
        Posted Jan 16, 2025 - 19:42 PST
        Investigating
        We are experiencing SMS delivery delays when sending messages to C-Spire Network in United States of America. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
        Posted Jan 16, 2025 - 18:51 PST
        This incident affected: CARRIER NETWORK (MMS Long Code, North America).