Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Taskrouter Task Data When Querying the Events API and Cumulative Stats for a Subset of Tasks may be Skewed
      Incident Report for Twilio
      Resolved
      TaskRouter Events API and Cumulative Statistics endpoints was degraded for 15 minutes between 04:12 and 04: 26 Pacific Time on 12/22/2021. During this period, the TaskRouter events were dropped and hence will affect the Events and Cumulative Statistics endpoints when queried for tasks that saw activity during the time of the outage.
      Posted Jan 05, 2022 - 13:19 PST
      Update
      TaskRouter Events API and Cumulative Statistics endpoints was degraded for 15 minutes between 04:12 and 04: 26 Pacific Time on 12/22/2021. During this period, the TaskRouter events were dropped and hence will affect the Events and Cumulative Statistics endpoints when queried for tasks that saw activity during the time of the outage.
      Posted Jan 05, 2022 - 13:10 PST
      Investigating
      We've become aware of a potential issue with Flex. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Jan 05, 2022 - 12:49 PST
      This incident affected: FLEX (TaskRouter).