Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Receipt Delay Sprint US Long Codes
Incident Report for Twilio
Resolved
This incident has been resolved.
Posted 3 months ago. Apr 23, 2019 - 04:39 PDT
Update
We are continuing to monitor for any furtherThe issue has been resolved. Delivery receipts for SMS sent to Sprint US handsets are being received without delays. We will continue to monitor closely for the next 30 minutes issues.
Posted 3 months ago. Apr 23, 2019 - 02:53 PDT
Monitoring
The issue has been resolved. Delivery receipts for SMS sent to Sprint US handsets are being received without delays. We will continue to monitor closely for the next 30 minutes
Posted 3 months ago. Apr 23, 2019 - 02:45 PDT
Investigating
We are observing an issue of delay in receiving delivery receipts for SMS sent from some Twilio US Long Codes to Sprint US handsets. We are working with our carrier partner to resolve the issue and will update as information becomes available.
Posted 3 months ago. Apr 22, 2019 - 23:32 PDT
This incident affected: CARRIER NETWORK (SMS Long Code, North America).