Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Flex UI connection issues
      Incident Report for Twilio
      Resolved
      The issue affecting Flex UI connection has been resolved. Flex UI connections and TaskRouter are operating normally.
      Posted Aug 04, 2022 - 17:07 PDT
      Update
      Our engineers have identified the issue Flex UI connection issues, and continue working to deploy a fix. We're seeing signs of recovery from some customer reports and internal dashboards. We expect to provide another update in 4 hour or as soon as more information becomes available
      Posted Aug 04, 2022 - 13:06 PDT
      Update
      Our engineers have identified the issue Flex UI connection issues, and continue working to deploy a fix. We're seeing signs of recovery from some customer reports and internal dashboards. We expect to provide another update in 2 hour or as soon as more information becomes available
      Posted Aug 04, 2022 - 11:05 PDT
      Identified
      Our engineers have identified the issue Flex UI connection issues, and are working to deploy a fix. We're seeing signs of recovery from some customer reports and internal dashboards. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted Aug 04, 2022 - 09:58 PDT
      Update
      After monitoring Flex UI connections and Taskrouter, we identified ongoing connectivity issues, and our engineers are currently investigating to find a resolution. We expect to provide another update in 30 minutes or as soon as more information becomes available.
      Posted Aug 04, 2022 - 09:22 PDT
      Monitoring
      Flex UI connections and Taskrouter are operating normally. We identified a few customer error reports and confirmed that the Flex platform is operating normally. We will continue to monitor for system stability. We'll provide another update in 30 minutes or as soon as more information becomes available.
      Posted Aug 04, 2022 - 08:50 PDT
      Update
      We are investigating a Flex UI connection issue. Customers may be unable to login to Flex or receive Taskrouter errors. Our engineering team is currently investigating to resolve the issue. We expect to provide another update in 30 minutes or as soon as more information becomes available
      Posted Aug 04, 2022 - 08:06 PDT
      Investigating
      Our monitoring systems have detected a potential issue with Taskrouter. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Aug 04, 2022 - 07:42 PDT
      This incident affected: FLEX (TaskRouter, Flex Application Platform).