Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
US Shortcode MMS Outbound Delays for a subset of Codes
Incident Report for Twilio
Resolved
Service is fully restored. This incident is resolved.
Posted Oct 09, 2020 - 05:34 PDT
Monitoring
We are seeing recovery of service and monitoring this issue until service is fully restored.
Posted Oct 09, 2020 - 04:27 PDT
Update
Our engineers are continuing to work with our carrier partner to resolve the issue. We expect to provide another update in 8 hours or as soon as more information becomes available.
Posted Oct 08, 2020 - 21:26 PDT
Update
We are still experiencing MMS delivery delays from a subset of US short codes to US carriers. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 4 hours or as soon as more information becomes available.
Posted Oct 08, 2020 - 17:26 PDT
Update
e are still experiencing MMS delivery delays from a subset of US short codes to US carriers. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Oct 08, 2020 - 15:20 PDT
Investigating
We are experiencing MMS delivery delays from a subset of US short codes to US Carriers. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Oct 08, 2020 - 14:15 PDT
This incident affected: CARRIER NETWORK (MMS Short Code, North America).