Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Sprint US SMS Carrier Partner Maintenance
Scheduled for Mar 14, 12:00 - 17:00 PDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Feb 20, 2020 - 17:01 PST
Scheduled
Our SMS carrier partner in the US is conducting planned maintenance from 14 March 2020 at 12:00 PST until 14 March 2020 at 17:00 PST. During the maintenance window, there could be intermittent delays delivering SMS to and from Sprint US handsets when sending to or from a subset of US shortcodes numbers.
Posted Feb 14, 2020 - 17:01 PST
This scheduled maintenance affects: CARRIER NETWORK (SMS Short Code, North America).