Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Zipwhip Gateway
      Issues related to Zipwhip's Services
        Scheduled maintenance
        System Metrics

        Elevated Error Rate and Latency with Adyen Payment Processing

        Incident Report for Twilio

        Resolved

        The issue causing elevated error rates and latency for customer integrations with Adyen platform has been resolved and the service is functioning normally at this time. Please refer here for more details - https://www.adyen.com/landing/platform-status.
        Posted Mar 16, 2023 - 14:42 PDT

        Investigating

        Twilio has detected elevated error rate and latency for customer integrations with Adyen platform. We will provide another update in 1 hour or as soon as more information becomes available. Customers are advised to use PayPal as a workaround. Please refer to https://www.adyen.com/landing/platform-status"
        Posted Mar 16, 2023 - 13:33 PDT
        This incident affected: TWILIO PLATFORM (Billing).