Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Delivery delays for shortcode messages to T-Mobile handsets
Incident Report for Twilio
Resolved
This incident has been resolved.
Posted 7 months ago. Jul 09, 2018 - 07:07 PDT
Update
All services are operating normally.
Posted 7 months ago. Jul 09, 2018 - 04:34 PDT
Update
Service appears to be stable. We are continuing to monitor the situation and will close the incident once resolution has been confirmed with our carrier partner.
Posted 7 months ago. Jul 09, 2018 - 03:11 PDT
Monitoring
We are seeing recovery of the problem. Our engineering team will continue to monitor the situation. We will post another update in 30 minutes.
Posted 7 months ago. Jul 09, 2018 - 02:30 PDT
Investigating
We are experiencing delays in delivering short code messages to some T-Mobile handsets. We are working with our carrier partners to restore service. We will post another update in 1 hour.
Posted 7 months ago. Jul 09, 2018 - 00:52 PDT
This incident affected: CARRIER NETWORK (SMS Short Code, North America).