Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Message delivery delay for US & CA Toll Free numbers
      Incident Report for Twilio
      Resolved
      All services are operating normally.
      Posted Jul 12, 2017 - 18:28 PDT
      Monitoring
      We are continuing to monitor the situation. We will post another update in two hours.
      Posted Jul 12, 2017 - 17:56 PDT
      Update
      We are seeing slight recovery of the delivery delay. Our engineering team will continue to monitor the recovery and provide another update in two hours.
      Posted Jul 12, 2017 - 15:40 PDT
      Update
      We are continuing to resolve the issue with the help of our carrier partner. Another update will be provided in two hours.
      Posted Jul 12, 2017 - 14:37 PDT
      Update
      We continue to work with our carrier partner to resolve this issue. We will provide an update within the next two hours.
      Posted Jul 12, 2017 - 12:29 PDT
      Update
      We are continuing to work with our carrier partner to resolve the issue. The impact is limited to US and Canada Toll free numbers. We will provide another update in an hour.
      Posted Jul 12, 2017 - 11:28 PDT
      Investigating
      We are currently working with our carrier partner to resolve an issue of delayed delivery of SMS messages to and from toll free numbers. We will provide another update within an hour.
      Posted Jul 12, 2017 - 10:12 PDT
      This incident affected: PROGRAMMABLE MESSAGING (SMS).