Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delay To Globe Network In Philippines Over Pre-Registered International SenderIDs
      Incident Report for Twilio
      Resolved
      We are no longer experiencing SMS delivery delays when sending messages to globe network in Philippines over pre-registered international sender IDs. This incident has been resolved.
      Posted Nov 16, 2022 - 01:11 PST
      Monitoring
      We are observing recovery in SMS delivery delays when sending messages to globe network in Philippines over pre-registered international sender IDs. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Nov 15, 2022 - 23:13 PST
      Update
      We continue to experience SMS delivery delays when sending messages to to globe network in Philippines over pre-registered international sender IDs. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Nov 15, 2022 - 21:13 PST
      Investigating
      We are experiencing SMS delivery delays when sending messages to to globe network in Philippines over pre-registered international sender IDs. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted Nov 15, 2022 - 20:13 PST
      This incident affected: CARRIER NETWORK (SMS, APAC).