Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Programmable Wireless SIM update delays
Incident Report for Twilio
Resolved
The downstream partner for Programmable Wireless has fully recovered and all delayed usage records for the period during the incident have been processed.
Posted 3 months ago. Apr 12, 2019 - 15:37 PDT
Monitoring
The downstream partner for Programmable Wireless has fully recovered from the earlier outage. Updates to Usage Records and billing for Data Usage and Commands for the time during the outage period are being processed as they are received.
Posted 3 months ago. Apr 10, 2019 - 23:33 PDT
Update
Our downstream partner has partially recovered and update requests for Programmable Wireless SIMs are being processed. SIMs that were stuck in `Scheduled` will move to `Updating` and then to an editable status once the update has completed. Usage Records and billing for Data and Commands may still be delayed until our partner fully recovers.
Posted 3 months ago. Apr 10, 2019 - 12:18 PDT
Identified
Our downstream partner for Programmable Wireless SIMs is continuing to resolve the root cause of the outage. SIMs with Status 'Scheduled' have their updates queued and will be applied once the partner recovers. The reporting and billing for Data Usage and Commands may also be delayed during this period. Full service restoration is now estimated to be 6 pm PDT. We will continue to provide updates as the timeline changes.
Posted 3 months ago. Apr 10, 2019 - 08:05 PDT
Update
Our downstream partner for Programmable Wireless SIMs is continuing to investigate the root cause of and recover from an outage. SIMs with Status 'Scheduled' have their updates queued and will be applied once the partner recovers. The reporting and billing for Data Usage and Commands may also be delayed during this period. Current estimate is services will be back to normal at 7 AM PDT. We will continue to provide updates as the timeline changes.
Posted 3 months ago. Apr 09, 2019 - 21:43 PDT
Investigating
Our downstream partner for Programmable Wireless SIMs is conducting emergency maintenance. This started at 8 AM PT on April 9, 2019. Users are experiencing delays in changing the Status or Rate Plan of their SIMs. SIMs with Status 'Scheduled' will have their updates applied once the partner is available again. Users will also see a delay in updates to UsageRecords. We are in close contact with our partner and working with them to resolve this as quickly as possible.
Posted 3 months ago. Apr 09, 2019 - 16:58 PDT
This incident affected: PROGRAMMABLE WIRELESS.