Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Data Usage reporting and Billing Delayed for Programmable Wireless
Incident Report for Twilio
Resolved
We have fully investigated the Programmable Wireless issue triggered by our automated alert, and it was determined that there is no customer impact. All systems are operational.
Posted Jul 18, 2020 - 16:21 PDT
Identified
We are currently seeing Data usage reporting and billing delayed due to missing usage records for Programmable Wireless (PW) and Narrow Band (NB) SIM cards. Our partner is currently working on a solution with the vendor.
Posted Jul 18, 2020 - 15:53 PDT
Investigating
Our monitoring systems have detected a potential issue regarding missing usage records for Programmable Wireless (PW) and Narrow Band (NB) SIM cards from T-Mobile. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Jul 18, 2020 - 15:51 PDT
This incident affected: INTERNET OF THINGS (Programmable Wireless).