The HTTP 5xx errors for Twilio Programmable Messaging API and Verify API have been resolved and the services are operating normally at this time.
Posted Mar 05, 2026 - 14:16 PST
Monitoring
We are observing a recovery in the rate of HTTP 5xx errors for Twilio Programmable Messaging API and Verify API. We will be monitoring the services to ensure a full recovery and provide another update in 30 minutes or as soon as more information becomes available.
Posted Mar 05, 2026 - 13:41 PST
Update
We are continuing to investigate an elevated rate of HTTP 5xx errors for Twilio Programmable Messaging API and Verify API. Our engineers are working on the issue, and we will provide another update in 2 hours or as soon as more information becomes available.
Posted Mar 05, 2026 - 13:16 PST
Update
We are currently investigating an elevated rate of HTTP 5xx errors for Twilio Programmable Messaging API and Verify API. Our engineers are working on the issue, and we will provide another update in 1 hour or as soon as more information becomes available.
Posted Mar 05, 2026 - 12:13 PST
Update
Twilio customers may be experiencing Twilio Programmable Messaging API was partially degraded starting from Mar 5th, 2026, 11:31 PST to 11:36 PST. Our team is actively investigating this issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Mar 05, 2026 - 12:05 PST
Investigating
Our monitoring systems have detected a potential issue with Twilio Programmable Messaging API was partially degraded starting from Mar 5th, 2026, 11:31 PST to 11:36 PST. Our engineers have been alerted and are investigating. We will provide an update when we have more details.
Posted Mar 05, 2026 - 11:56 PST
This incident affected: ACCOUNT SECURITY (Verify) and PROGRAMMABLE MESSAGING (Programmable Messaging API).