Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Delay to Robi Network in Bangladesh
Incident Report for Twilio
Resolved
We are no longer experiencing delivery delays to Robi Network in Bangladesh. This incident has been resolved.
Posted Nov 08, 2020 - 21:51 PST
Update
We are continuing to work with our carrier partner to resolve the issue. We expect to provide another update in 24 hours or as soon as more information becomes available.
Posted Nov 07, 2020 - 21:58 PST
Update
We are continuing to work with our carrier partner to resolve the issue. We expect to provide another update in 24 hours or as soon as more information becomes available.
Posted Nov 06, 2020 - 21:57 PST
Investigating
We are continuing to work with our carrier partner to resolve the issue. We expect to provide another update in 16 hours or as soon as more information becomes available.
Posted Nov 06, 2020 - 05:50 PST
Monitoring
We are observing recovery in delivery report delays when sending towards Bangladesh Airtel. We will continue monitoring the service to ensure a full recovery. We will provide another update in 6 hours or as soon as more information becomes available.
Posted Nov 06, 2020 - 01:38 PST
Update
We are continuing to investigate this issue.
Posted Nov 05, 2020 - 14:31 PST
Update
We are continuing to work with our carrier partner to resolve the issue. We expect to provide another update in 16 hours or as soon as more information becomes available.
Posted Nov 05, 2020 - 14:30 PST
Update
We are continuing to work with our carrier partner to resolve the issue. We expect to provide another update in 8 hours or as soon as more information becomes available.
Posted Nov 05, 2020 - 06:38 PST
Update
We are continuing to work with our carrier partner to resolve the issue. We expect to provide another update in 8 hours or as soon as more information becomes available.
Posted Nov 04, 2020 - 13:44 PST
Update
We are continuing to work with our carrier partner to resolve the issue. We expect to provide another update in 4 hours or as soon as more information becomes available.
Posted Nov 04, 2020 - 09:44 PST
Update
We are continuing to work with our carrier partner to resolve the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Nov 04, 2020 - 07:44 PST
Update
We are experiencing huge SMS delivery delays when sending messages to Bangladesh Robi. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Nov 04, 2020 - 06:44 PST
Investigating
Our monitoring systems have detected delays in the outbound SMS messages towards Bangladesh Airtel. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Nov 04, 2020 - 06:36 PST
This incident affected: CARRIER NETWORK (SMS, APAC, SMS Delivery Notifications & Status Callbacks).