Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Delay To Mobilis Algeria
Incident Report for Twilio
Resolved
We are no longer experiencing delivery delays to Algeria Mobilis network. This incident has been resolved.
Posted Jan 10, 2021 - 04:41 PST
Update
We are continuing to work with our carrier partner to resolve the issue. We expect to provide another update in 16 hours or as soon as more information becomes available.
Posted Jan 10, 2021 - 03:34 PST
Update
We are continuing to work with our carrier partner to resolve the issue. We expect to provide another update in 8 hours or as soon as more information becomes available.
Posted Jan 09, 2021 - 19:44 PST
Update
We are continuing to work with our carrier partner to resolve the issue. We expect to provide another update in 4 hours or as soon as more information becomes available.
Posted Jan 09, 2021 - 14:43 PST
Update
We are continuing to work with our carrier partner to resolve the issue. We expect to provide another update in 4 hours or as soon as more information becomes available.
Posted Jan 09, 2021 - 14:43 PST
Update
We are continuing to work with our carrier partner to resolve the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Jan 09, 2021 - 12:49 PST
Update
We are experiencing delivery delays to Mobilis network in Algeria. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 60 minutes or as soon as more information becomes available.
Posted Jan 09, 2021 - 11:41 PST
Investigating
Our monitoring systems have detected a potential issue with SMS Delivery delays in Algeria. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Jan 09, 2021 - 11:03 PST
This incident affected: CARRIER NETWORK (SMS Long Code, North America).