Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Toll-Free SMS Delivery Delays to Verizon
Incident Report for Twilio
Resolved
We are no longer experiencing delivery delays of concatenated messages to Verizon. This incident has been resolved.
Posted Oct 09, 2020 - 17:25 PDT
Monitoring
We are observing successful SMS delivery of concatenated messages to Verizon users for the last 5 minutes. We will continue to monitor to ensure full service recovery. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Oct 09, 2020 - 16:20 PDT
Update
We are still experiencing Twilio Toll-Free SMS delivery delays when sending concatenated messages to Verizon users in the US for a subset of our customers. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Oct 09, 2020 - 15:48 PDT
Update
We are experiencing Twilio Toll-Free SMS delivery delays when sending concatenated messages to Verizon users in the US for a subset of our customers. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Oct 09, 2020 - 14:22 PDT
Investigating
Our monitoring systems have detected a potential issue with Toll-Free SMS delays. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Oct 09, 2020 - 14:11 PDT
This incident affected: CARRIER NETWORK (SMS Toll-Free, North America).