Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Report Delays to Digicel Network in Papua New Guinea
      Incident Report for Twilio
      Resolved
      We are no longer experiencing SMS delivery report delays when sending messages to Digicel network in Papua New Guinea. This incident has been resolved.
      Posted Sep 13, 2022 - 23:46 PDT
      Monitoring
      We are observing recovery in SMS delivery report delays when sending messages to Digicel network in Papua New Guinea. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Sep 13, 2022 - 21:53 PDT
      Update
      We are continuing to experience SMS delivery report delays when sending messages to Digicel network in Papua New Guinea. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 4 hours or as soon as more information becomes available.
      Posted Sep 13, 2022 - 21:09 PDT
      Update
      We are experiencing SMS delivery report delays when sending messages to Digicel network in Papua New Guinea. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Sep 13, 2022 - 19:07 PDT
      Update
      We are experiencing SMS delivery report delays when sending messages to Digicel network in Papua New Guinea. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted Sep 13, 2022 - 18:07 PDT
      Investigating
      Our monitoring systems have detected a potential issue with SMS delivery report delays to Digicel Papua network in New Guinea. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Sep 13, 2022 - 18:01 PDT
      This incident affected: CARRIER NETWORK (SMS Delivery Notifications & Status Callbacks).