Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Failures on Telkom Network in Kenya
      Incident Report for Twilio
      Resolved
      We are no longer experiencing SMS delivery failures to Telkom network in Kenya. This incident has been resolved.
      Posted Feb 02, 2023 - 06:45 PST
      Monitoring
      We are observing successful SMS delivery to Telkom network in Kenya. We will continue to monitor to ensure full service recovery. We expect to provide another update in 2 hours or as soon as more information becomes available.
      Posted Feb 02, 2023 - 04:53 PST
      Update
      We continue to experience SMS delivery failures Telkom network in Kenya. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 4 hours or as soon as more information becomes available.
      Posted Feb 02, 2023 - 01:01 PST
      Update
      We continue to experience SMS delivery failures Telkom network in Kenya. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 4 hours or as soon as more information becomes available.
      Posted Feb 02, 2023 - 01:00 PST
      Update
      We are experiencing SMS delivery failures Telkom network in Kenya . Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
      Posted Feb 01, 2023 - 23:08 PST
      Investigating
      We are experiencing MMS/SMS delivery failures Telkom network in Kenya . Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted Feb 01, 2023 - 22:21 PST