Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Inbound call failures in Greece.
      Incident Report for Twilio
      Resolved
      This incident has been resolved.
      Posted Apr 12, 2017 - 21:15 PDT
      Identified
      We continue to experience inbound call failures to Greece. Our carrier partners are working to restore service as quickly as possible. We will provide another update as soon as we have more information.
      Posted Apr 12, 2017 - 19:27 PDT
      Investigating
      We are currently experiencing inbound call failures to 50% of numbers in Greece. Our engineers are working with our carrier partner to resolve. We will provide an update as soon as possible.
      Posted Apr 12, 2017 - 18:24 PDT
      This incident affected: PROGRAMMABLE VOICE (PSTN).