Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Studio Execution Timers Failing
Incident Report for Twilio
Resolved
Our Engineers have resolved this issue where Studio execution timers are failing. All services are functional and operational now.
Posted Sep 29, 2020 - 18:47 PDT
Investigating
We are investigating an issue where Studio execution timers are failing. Studio Widgets that have a timeout may not execute in the timeframe expected. Our engineers are working to resolve the issue. We will provide an update in 4 hour or as soon as more information becomes available.
Posted Sep 29, 2020 - 14:00 PDT
Monitoring
We are observing a recovery of the Studio execution timers. We will continue to monitor to ensure full service recovery. We expect to provide another update in 30 minutes or as soon as more information becomes available.
Posted Sep 29, 2020 - 12:46 PDT
Update
We are still experiencing an issue causing Studio execution timers to fail. Studio Widgets that have a timeout may not execute in the timeframe expected. Our engineers are working to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Sep 29, 2020 - 11:40 PDT
Update
We are investigating an issue where Studio execution timers are failing. Studio Widgets that have a timeout may not execute in the timeframe expected. Our engineers are working to resolve the issue. We will provide an update in 1 hour or as soon as more information becomes available.
Posted Sep 29, 2020 - 10:42 PDT
Investigating
Our monitoring systems have detected a potential issue. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Sep 29, 2020 - 10:35 PDT
This incident affected: SERVERLESS (Studio).