Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 05, 2025 - 12:00 PST
Scheduled
The Tele2 network in Russia is conducting a series of planned maintenances from 05 March 2025 at 12:00 PST until 31 March 2025 at 17:00 PDT. During the maintenance window, there could be intermittent delays delivering SMS to Tele2 Russia handsets.
Note, the maintenance will be carried out on each of the following dates and times:
05 March 2025 at 12:00 PST until 05 March 2025 at 16:00 PST
10 March 2025 at 13:00 PDT until 10 March 2025 at 17:00 PDT
12 March 2025 at 13:00 PDT until 12 March 2025 at 17:00 PDT
17 March 2025 at 13:00 PDT until 17 March 2025 at 17:00 PDT
19 March 2025 at 13:00 PDT until 19 March 2025 at 17:00 PDT
24 March 2025 at 13:00 PDT until 24 March 2025 at 17:00 PDT
26 March 2025 at 13:00 PDT until 26 March 2025 at 17:00 PDT
31 March 2025 at 13:00 PDT until 31 March 2025 at 17:00 PDT
Posted Mar 04, 2025 - 08:05 PST
This scheduled maintenance affected: CARRIER NETWORK (SMS, Europe).