Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Degradation Towards Verizon US
Incident Report for Twilio
Resolved
This incident has been resolved.
Posted Dec 11, 2019 - 01:38 PST
Monitoring
We are observing recovery and we will confirm further once this incident is resolved.
Posted Dec 11, 2019 - 01:15 PST
Investigating
We are observing delivery degradation towards Verizon (311-489) is degraded via Short Codes and US-Toll free numbers in the USA. We are working with our carrier partners to resolve the issue and will provide an update as soon as we have more information.
Posted Dec 11, 2019 - 00:21 PST
This incident affected: CARRIER NETWORK (SMS Short Code, North America, SMS Toll-Free, North America).