Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Zipwhip Gateway
      Issues related to Zipwhip's Services
        Scheduled maintenance
        System Metrics

        Call Quality Issues to a Subset Of Mexico Phone Numbers

        Incident Report for Twilio

        Resolved

        The issue causing poor call quality on outbound calls to a subset of Mexico phone numbers has been resolved, and the service is functioning normally at this time.
        Posted Apr 10, 2025 - 17:57 PDT

        Update

        We continue to observe recovery from poor call quality on outbound calls to a subset of Mexico phone numbers. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
        Posted Apr 10, 2025 - 15:57 PDT

        Monitoring

        We are observing recovery from poor call quality on outbound calls to a subset of Mexico phone numbers. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
        Posted Apr 10, 2025 - 13:57 PDT

        Update

        We are observing poor call quality on outbound calls to a subset of Mexico phone numbers. We are currently working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
        Posted Apr 10, 2025 - 13:17 PDT

        Investigating

        Our monitoring systems have detected a potential issue with poor call quality on outbound calls to a subset of Mexico phone numbers. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
        Posted Apr 10, 2025 - 13:14 PDT
        This incident affected: CARRIER NETWORK (Voice, Latin America).