Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Delays to U.S. T-Mobile via Toll-Free numbers
Incident Report for Twilio
Resolved
SMS delivery from Twilio's toll-free numbers to T-Mobile U.S. is successful. This incident has been resolved.
Posted Sep 18, 2020 - 15:26 PDT
Monitoring
We are observing successful SMS delivery to T-Mobile U.S. from Twilio's toll-free numbers. We will continue to monitor to ensure a full recovery of the service. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Sep 18, 2020 - 14:15 PDT
Update
SMS delivery delays to T-Mobile U.S. from Twilio's toll-free numbers continue to occur. Our engineers continue working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Sep 18, 2020 - 12:45 PDT
Update
We are experiencing SMS delivery delays to U.S. T-Mobile via Toll-free numbers. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Sep 18, 2020 - 11:47 PDT
Investigating
Our monitoring systems have detected a potential issue. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Sep 18, 2020 - 11:40 PDT
This incident affected: CARRIER NETWORK (SMS Toll-Free, North America).