Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Failures to MTN Rwanda
Incident Report for Twilio
Resolved
We are no longer experiencing SMS delivery failures to MTN Rwanda. This incident has been resolved.
Posted Aug 03, 2021 - 10:11 PDT
Monitoring
We are observing successful SMS delivery when sending to MTN Rwanda for the last 60 minutes. We will continue to monitor to ensure full service recovery. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Aug 03, 2021 - 08:21 PDT
Update
We are still experiencing SMS delivery failures when sending to MTN Rwanda. Our engineers are still working with our carrier partner to resolve the issue. We will provide another update in 24 hours or as soon as more information becomes available.
Posted Aug 03, 2021 - 06:46 PDT
Update
We are still experiencing SMS delivery failures when sending to MTN Rwanda (635-10). Our engineers are still working with our carrier partner to resolve the issue. We will provide another update in 24 hours or as soon as more information becomes available.
Posted Aug 02, 2021 - 06:55 PDT
Update
We are still experiencing SMS delivery delays when sending messages to MTN Rwanda. Our engineers are still working with our carrier partner to resolve the issue. We will provide another update in 16 hours or as soon as more information becomes available.
Posted Aug 01, 2021 - 15:00 PDT
Update
We are still experiencing SMS delivery delays when sending messages to MTN Rwanda (635-10), recently we noticed that some messages started failing as well beside some of them are still delayed. Our engineers are still working with our carrier partner to resolve the issue. We will provide another update in 8 hour or as soon as more information becomes available.
Posted Aug 01, 2021 - 07:00 PDT
Update
We are still experiencing SMS delivery delays when sending messages to MTN Rwanda (635-10), recently we noticed that some messages started failing as well beside some of them are still delayed. Our engineers are still working with our carrier partner to resolve the issue. We will provide another update in 4 hour or as soon as more information becomes available.
Posted Aug 01, 2021 - 03:06 PDT
Update
We are still experiencing SMS delivery delays when sending messages to MTN Rwanda (635-10). Our engineers are still working with our carrier partner to resolve the issue. We will provide another update in 2 hour or as soon as more information becomes available.
Posted Aug 01, 2021 - 01:05 PDT
Investigating
We are experiencing SMS delivery delays when sending messages to MTN Rwanda (635-10). Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Aug 01, 2021 - 00:06 PDT
This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).