Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Delays to the Ooredoo Network in Algeria
Incident Report for Twilio
Resolved
We are no longer experiencing delivery report delays when sending to Ooredoo (formerly Nedjma) network in Algeria. This incident has been resolved.
Posted Sep 17, 2020 - 01:52 PDT
Update
We are observing recovery in delivery report delays [when sending to Ooredoo (formerly Nedjma) network in Algeria. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2hours or sooner once more information becomes available.
Posted Sep 17, 2020 - 00:20 PDT
Monitoring
We are observing recovery in delivery report delays [when sending to Ooredoo (formerly Nedjma) network in Algeria. We will continue monitoring the service to ensure a full recovery. We will provide another update in 30 mins or sooner once more information becomes available.
Posted Sep 16, 2020 - 22:43 PDT
Update
We continue to observe SMS delays to Ooredoo in Algeria and continue to work with our carrier partners towards resolution. We will provide additional updates as soon as we have more information.
Posted Sep 16, 2020 - 20:41 PDT
Update
We continue to observe SMS delays to Ooredoo in Algeria and continue to work with our carrier partners towards resolution. We will provide additional updates as soon as we have more information.
Posted Sep 16, 2020 - 19:21 PDT
Update
We continue to observe SMS delays to Ooredoo in Algeria and continue to work with our carrier partners towards resolution. We will provide additional updates as soon as we have more information.
Posted Sep 16, 2020 - 17:05 PDT
Update
We are observing SMS delivery delays for messages from Twilio to the Ooredoo (formerly Nedjma) network in Algeria. Our engineers are working with our carrier partners to resolve the issue. We will provide additional updates as soon we have more information.
Posted Sep 16, 2020 - 15:41 PDT
Investigating
Our monitoring systems have detected a potential issue regarding Programmable SMS. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Sep 16, 2020 - 15:31 PDT
This incident affected: CARRIER NETWORK (SMS, Middle East & Africa, SMS Delivery Notifications & Status Callbacks).