Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Degraded network conditions
Incident Report for Twilio
Resolved
All services are operating normally.
Posted 6 days ago. Aug 13, 2019 - 01:09 PDT
Monitoring
All services are operating normally. Our team will continue to monitor.
Posted 6 days ago. Aug 13, 2019 - 00:26 PDT
Investigating
Command routes are experiencing instability which can cause delays in processing commands to and from some SIM cards. We are working with partners and have identified the issue and engineers are actively working to resolve.
Posted 6 days ago. Aug 12, 2019 - 23:50 PDT
This incident affected: PROGRAMMABLE WIRELESS.