Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Degradation toward Hormuud Somalia
Incident Report for Twilio
Resolved
This incident has been resolved.
Posted Dec 08, 2019 - 20:04 PST
Monitoring
We are seeing recovery on the delivery degradation for Hormuud Somalia. We'll continue to monitor and provide updates if there are any changes.
Posted Dec 08, 2019 - 19:24 PST
Update
We are continuing to observing message delivery degradation. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
Posted Dec 08, 2019 - 13:17 PST
Investigating
We are currently observing message delivery degradation to the Hormuud network in Somalia. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
Posted Dec 08, 2019 - 11:03 PST
This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).