Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Outbound shortcode delivery delays and failures towards T-Mobile.
Incident Report for Twilio
Resolved
This incident has been resolved.
Posted Feb 12, 2020 - 11:24 PST
Monitoring
We're seeing a recovery in the delivery of shortcode messages to T-Mobile. We'll continue monitoring and provide further updates as necessary.
Posted Feb 12, 2020 - 10:57 PST
Identified
We are seeing a recurrence of delays and delivery failures for short codes in the US when the receiving carrier is T-Mobile. We'll continue working with our carrier partners to resolve this and post further updates as necessary.
Posted Feb 12, 2020 - 10:29 PST
Monitoring
We're seeing a recovery in the delivery of shortcode messages to US carriers. We'll continue monitoring and provide further updates as necessary.
Posted Feb 12, 2020 - 09:47 PST
Investigating
We are experiencing shortcode delivery delays and failures for some messages towards all carriers in the US. We are working with our carrier partners to resolve this issue. We will provide further updates as soon as they become available.
Posted Feb 12, 2020 - 08:41 PST
This incident affected: CARRIER NETWORK (SMS Short Code, North America).