Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delays to Multiple Network over Toll-Free Numbers in US
      Incident Report for Twilio
      Resolved
      There is an ongoing planned maintenance by our SMS carrier partner in the US from 24th Feb 2021 at 20:00 PDT until 24th Feb 2021 at 23:59 PDT. During the maintenance window, there could be intermittent delays delivering SMS/MMS to and from US handsets via US toll-free numbers.
      Closing this incident as updates on the maintenance can be found here - https://status.twilio.com/incidents/c1wm6w8cg92t
      Posted Feb 24, 2021 - 21:16 PST
      Investigating
      We are experiencing SMS delivery delays when sending messages to multiple network over Toll-Free numbers in US. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in an hour or as soon as more information becomes available.
      Posted Feb 24, 2021 - 20:46 PST
      This incident affected: CARRIER NETWORK (SMS Toll-Free, North America).