Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Flex Insights Login Issue
      Incident Report for Twilio
      Resolved
      Flex Insights issues have been finally addressed during the maintenance period. Tests have been done and confirmed all previous related problems are fixed. This incident has been resolved.
      Posted Oct 23, 2020 - 22:41 PDT
      Update
      We have scheduled a maintenance to address the Flex Insights issues that will take place on 10/23 at 21:00 PDT. During the maintenance, no new users can be added nor existing ones updated for Flex Insights. Existing users won't be affected and can use the service without any issues.
      Posted Oct 23, 2020 - 12:21 PDT
      Update
      We are still addressing the issue affecting the provisioning of Flex Insights accounts. We expect to provide another update in 16 hours or when we have further information.
      Posted Oct 23, 2020 - 02:32 PDT
      Identified
      We are still addressing the issue affecting the provisioning of Flex Insights accounts. We expect to provide another update in 8 hours.
      Posted Oct 22, 2020 - 11:59 PDT
      Update
      We are still addressing the issue affecting the provisioning of Flex Insights accounts. We expect to provide another update in 4 hours.
      Posted Oct 22, 2020 - 08:02 PDT
      Update
      We are addressing the issue affecting the provisioning of Flex Insights accounts. We expect to provide another update in 2 hours.
      Posted Oct 22, 2020 - 06:00 PDT
      Update
      Existing customers can now log in and access their Flex Insights accounts, however customers currently can not provision new Flex Insights accounts. We continue to investigate this issue and we will provide an update in an hour or once we have more information.
      Posted Oct 22, 2020 - 05:07 PDT
      Update
      We are continuing to investigate this issue.
      Posted Oct 22, 2020 - 04:29 PDT
      Investigating
      Our engineering team is investigating an issue where existing Flex Insights users cannot login to their account, customers who are already logged in won’t be impacted. We continue to investigate this issue and we will provide an update in an hour or once we get some more information.
      Posted Oct 22, 2020 - 04:22 PDT
      This incident affected: FLEX (Flex Insights).