Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Increased latency for SMS, Voice, Studio, and Taskrouter products
      Incident Report for Twilio
      Resolved
      This incident has been resolved.
      Posted Mar 30, 2020 - 14:29 PDT
      Monitoring
      A fix has been implemented and we are monitoring the results.
      Posted Mar 30, 2020 - 14:22 PDT
      Update
      We are experiencing an increased latency and 500 level errors for Rest API operations involving SMS, Voice, and Taskrouter. This is also impacting the performance of our Studio product. Our engineering team is actively investigating the issue
      Posted Mar 30, 2020 - 14:15 PDT
      Update
      We are continuing to investigate this issue.
      Posted Mar 30, 2020 - 14:04 PDT
      Update
      We are continuing to investigate this issue.
      Posted Mar 30, 2020 - 13:50 PDT
      Investigating
      Our monitoring systems have detected a potential issue. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Mar 30, 2020 - 13:46 PDT
      This incident affected: FLEX (TaskRouter), PROGRAMMABLE VOICE (PSTN, SIP Interface, Client Web, Client Mobile, Conference, Recording, Queue, Text-to-Speech, Recording Transcriptions, TwiML, Voice Insights, Speech Recognition), SERVERLESS (Studio), DEVELOPER TOOLS (REST API), and PROGRAMMABLE MESSAGING (SMS).