Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS and MMS Delivery Delays for a Subset of Twilio Short Codes
      Incident Report for Twilio
      Resolved
      We are no longer experiencing SMS and MMS delivery delays when sending messages to US networks from a subset of Twilio short codes. This incident has been resolved.
      Posted Sep 26, 2022 - 11:57 PDT
      Monitoring
      We are observing recovery in SMS and MMS delivery delays when sending messages to US networks from a subset of Twilio short codes. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Sep 26, 2022 - 09:53 PDT
      Update
      We are experiencing SMS and MMS delivery delays when sending messages to US networks from a subset of Twilio short codes. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted Sep 26, 2022 - 09:21 PDT
      Investigating
      Our monitoring systems have detected a potential issue with SMS and MMS delivery delays for a subset of Twilio short codes. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Sep 26, 2022 - 09:12 PDT
      This incident affected: CARRIER NETWORK (SMS Short Code, North America, MMS Short Code, North America).