Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Delayed Usage and Billing Reporting for Programmable Wireless
      Incident Report for Twilio
      Resolved
      Data usage and billing report delays are missing due to planned maintenance by network partners and will start to resolve at 18:00 PDT. We expect these records to be recovered by October 21 at 06:00 PDT.
      Posted Oct 20, 2021 - 16:50 PDT
      Update
      We are still experiencing data usage and billing report delays with the Programmable Wireless product. The issue has no impact on connectivity. We are working on recovering the missing usage records once available. We will provide another update in 2 hours or sooner once more information becomes available.
      Posted Oct 20, 2021 - 14:42 PDT
      Investigating
      We are experiencing data usage and billing report delays with the Programmable Wireless product. The issue has no impact on connectivity. We are working on recovering the missing usage records once available. We will provide another update in 1 hour or sooner once more information becomes available.
      Posted Oct 20, 2021 - 13:46 PDT
      This incident affected: TWILIO PLATFORM (Billing).