Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Delays on outbound messages
      Incident Report for Twilio
      Resolved
      We are seeing message queuing has returned to normal.
      Posted Nov 06, 2015 - 11:06 PST
      Investigating
      We are currently investigating an issue with delays on outbound messages.
      Posted Nov 06, 2015 - 10:50 PST