Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Zipwhip Gateway
      Issues related to Zipwhip's Services
        Scheduled maintenance
        System Metrics

        500 Errors for Twilio Phone Numbers Provisioning

        Incident Report for Twilio

        Resolved

        Twilio phone numbers provisioning was degraded for 23 days, 8 hours, and 3 minutes between 2025-04-28 at 23:40:24 PDT and 2025-05-22 at 07:43:38 PDT. During this period of time, 18 Phone Numbers in our inventory were mistakenly made available for provisioning even if they couldn't be provisioned and for this reason some customers have experienced an HTTP 500 Server error. This incident has been resolved.
        Posted May 22, 2025 - 14:54 PDT

        Monitoring

        Our engineers are currently investigating the customer impact of a retroactive issue with phone numbers provisioning. We will follow up and provide customer impact details within 2 hours.
        Posted May 22, 2025 - 14:04 PDT