Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delays with Toll Free Numbers and Verizon
      Incident Report for Twilio
      Resolved
      We are no longer experiencing delays with Toll Free numbers and Verizon. This incident has been resolved.
      Posted Mar 13, 2020 - 13:05 PDT
      Investigating
      We are experiencing Inbound SMS delivery delays on Toll Free numbers when receiving messages from Verizon. We are also experiencing delays for Message Statuses Events from Toll Free numbers to Verizon. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
      Posted Mar 13, 2020 - 12:43 PDT
      This incident affected: CARRIER NETWORK (SMS Toll-Free, North America).