Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Issues When Adding Credit Card in Console
      Incident Report for Twilio
      Resolved
      Adding credit card in the Console issue has been resolved and console is operating normally at this time.
      Posted Sep 18, 2023 - 12:12 PDT
      Update
      We continue investigating issues when adding credit card in the Console. Customers may face the following error: “There was an error adding your card information”. Our engineers are working on the issue, and we will provide another update in 4 hours or as soon as more information becomes available.
      Posted Sep 18, 2023 - 09:19 PDT
      Update
      We are still investigating issues when adding credit card in the Console. Customers may face the following error: “There was an error adding your card information”. Our engineers are working on the issue, and we will provide another update in 2 hours or as soon as more information becomes available.
      Posted Sep 18, 2023 - 07:17 PDT
      Update
      We are currently investigating issues when adding credit card in the Console. Customers may face the following error: “There was an error adding your card information”. Our engineers are working on the issue, and we will provide another update in 1 hour or as soon as more information becomes available.
      Posted Sep 18, 2023 - 06:17 PDT
      Investigating
      Our monitoring systems have detected a potential issue when adding a credit card in the console. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Sep 18, 2023 - 06:07 PDT
      This incident affected: TWILIO PLATFORM (Billing).