Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Billing Delays for a Subset of Twilio Accounts
Incident Report for Twilio
Resolved
This incident has been resolved.
Posted Nov 20, 2019 - 12:49 PST
Monitoring
A fix has been implemented and we are monitoring results.
Posted Nov 20, 2019 - 11:59 PST
Identified
The issue has been identified and a fix is being implemented. We are continuing to work directly with any impacted customers.
Posted Nov 20, 2019 - 10:36 PST
Investigating
We are currently experiencing delays with account recharges for a subset of accounts. Our engineering team is engaged and working towards a resolution. We are working directly with affected customers to minimize impact. We will post an additional update shortly.
Posted Nov 20, 2019 - 10:15 PST
This incident affected: TWILIO PLATFORM (Billing).