Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Carriers around the world are experiencing capacity issues because of increased demand on their networks due to COVID-19. This may result in voice quality issues, busy signals, or other errors on your phone calls. Twilio continues to monitor the health of the global carrier networks and we are publishing the most up-to-date information on our Worldwide Telephony Network Congestion page.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
On Call Engineers are Investigating
Incident Report for Twilio
Resolved
All systems are operational
Posted Mar 14, 2020 - 04:44 PDT
Investigating
Our monitoring systems have detected a potential issue with calls to Twilio's South African numbers. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Mar 14, 2020 - 04:23 PDT
This incident affected: CARRIER NETWORK (Voice, Middle East & Africa).