Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Delays to Claro Network in Domincan Republic
Incident Report for Twilio
Resolved
We are no longer experiencing delivery delays when sending messages to the Claro network in Dominican Republic. This incident has been resolved.
Posted Nov 10, 2020 - 18:25 PST
Monitoring
We are observing recovery in delivery delays when sending messages to the Claro network in Dominican Republic. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Nov 10, 2020 - 17:28 PST
Update
We continue to observe intermittent SMS delivery delays when sending messages to the Claro network in Dominican Republic. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 4 hours or as soon as more information becomes available.
Posted Nov 10, 2020 - 14:55 PST
Investigating
We are observing intermittent SMS delivery delays when sending messages to the Claro network in Dominican Republic. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Nov 10, 2020 - 13:01 PST
Monitoring
We are observing recovery in delivery delays when sending messages to the Claro network in Domincan Republic. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Nov 10, 2020 - 10:59 PST
Update
We are still experiencing SMS delivery delays when sending messages to the Claro network in Domincan Republic. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Nov 10, 2020 - 09:04 PST
Update
We are experiencing SMS delivery delays when sending messages to the Claro network in Domincan Republic. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Nov 10, 2020 - 08:05 PST
Investigating
Our monitoring systems have detected a potential issue. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Nov 10, 2020 - 07:56 PST
This incident affected: CARRIER NETWORK (SMS, Latin America).