Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Outbound Toll Free SMS delays in US
Incident Report for Twilio
Resolved
The issue of delay in messages and delay in DLRs has been resolved. All systems are operating normally.
Posted 3 months ago. Dec 23, 2018 - 13:48 PST
Monitoring
We are seeing recovery for an issue of delay in delivery of messages and delay in receiving DLRs. Our engineers continue to monitor the service and we will update once we have confirmed that service is fully recovered.
Posted 3 months ago. Dec 23, 2018 - 13:09 PST
Update
We continue to experience delays for sending messages from Toll-free numbers towards US networks. DLRs are delayed, messages are still being delivered but in some cases delayed by approximately 60 seconds. Inbound messages from US networks are also being impacted with this issue. We continue to work with our carrier partners to resolve this issue. We will provide an update when we have further information.
Posted 3 months ago. Dec 23, 2018 - 12:00 PST
Update
We are continuing seeing delays to US networks. DLRs are delayed, messages are still being delivered but in some cases delayed by approximately 60 seconds. We continue to work with our partners to resolve this issue. We will provide an update when we have further information.
Posted 3 months ago. Dec 23, 2018 - 10:37 PST
Update
We are continuing seeing delays to US networks, primarily Sprint and T-Mobile. DLRs are delayed, messages are still being delivered but in some cases delayed by approximately 60 seconds. We will continue to investigate and work with our partners. We will provide an update when we have further information.
Posted 3 months ago. Dec 23, 2018 - 07:16 PST
Investigating
We have detected an issue with delays to US networks, primarily Sprint and TMobile. DLRs are delayed, messages are still being delivered but in some cases delayed. We will continue to investigate and work with our partners. We will provide an update when we have further information.
Posted 3 months ago. Dec 23, 2018 - 05:29 PST
This incident affected: PROGRAMMABLE MESSAGING (SMS).