Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Inbound Call Issues to a Subset of Twilio UK Phone Numbers
Incident Report for Twilio
Resolved
Our carrier partner confirmed that the issue causing inbound call failures to a subset of Twilio UK phone numbers had been resolved since 10:19 AM Pacific Time, and the service has been operational throughout the monitoring period. The incident is now resolved.
Posted May 04, 2021 - 12:27 PDT
Monitoring
We have started seeing recovery for inbound calls to a subset of Twilio UK phone numbers. We will continue to monitor to ensure a full recovery. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted May 04, 2021 - 10:51 PDT
Update
The issue causing inbound call problems to a subset of Twilio UK phone numbers has been identified. We are continuing to actively work with our carrier partner to resolve the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted May 04, 2021 - 10:14 PDT
Update
The issue causing inbound call problems to a subset of Twilio UK phone numbers has been identified. We are continuing to actively work with our carrier partner to resolve the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted May 04, 2021 - 08:15 PDT
Identified
The issue causing inbound call failures to a subset of Twilio UK phone numbers has been identified. We are actively working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted May 04, 2021 - 07:17 PDT
Investigating
We are observing an issue establishing inbound calls to a subset of Twilio UK phone numbers. We are currently working with our carrier partner to resolve the issue. We expect to provide another update in 30 minutes or as soon as more information becomes available.
Posted May 04, 2021 - 06:50 PDT
This incident affected: CARRIER NETWORK (Voice, Europe).