Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Delays to Liberia Orange
Incident Report for Twilio
Resolved
We are no longer experiencing SMS delivery delays when sending messages to Liberia Orange Network. This incident has been resolved.
Posted Jun 08, 2021 - 09:15 PDT
Monitoring
We are observing recovery of SMS delivery delays when texting to Liberia Orange Network. We will continue to monitor to ensure a full recovery. We expect to provide another update in 30 minutes or as soon as more information becomes available.
Posted Jun 08, 2021 - 08:50 PDT
Update
We are continuing to work with our carrier partner to investigate the SMS delivery delays root causes when texting to Liberia Orange Network. We will provide another update in 24 hours or as soon as more information becomes available.
Posted Jun 07, 2021 - 17:15 PDT
Update
We are continuing to work with our carrier partner to investigate the SMS delivery delays root causes when texting to Liberia Orange Network. We will provide another update in 24 hours or as soon as more information becomes available.
Posted Jun 06, 2021 - 17:09 PDT
Update
We are continuing to work with our carrier partner to investigate the SMS delivery delays root causes when texting to Liberia Orange Network. We will provide another update in 16 hours or as soon as more information becomes available.
Posted Jun 06, 2021 - 01:17 PDT
Update
We are continuing to work with our carrier partner to investigate the SMS delivery delays to Liberia Orange. We will provide another update in 8 hours or as soon as more information becomes available.
Posted Jun 05, 2021 - 17:24 PDT
Update
We are continuing to work with our carrier partner to investigate the SMS delivery delays to Liberia Orange. We will provide another update in 4 hours or as soon as more information becomes available.
Posted Jun 05, 2021 - 13:31 PDT
Update
We are continuing to work with our carrier partner to investigate the SMS delivery delays to Liberia Orange. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Jun 05, 2021 - 11:36 PDT
Update
We are continuing to work with our carrier partner to investigate the SMS Delivery Delays to Liberia Orange. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Jun 05, 2021 - 09:23 PDT
Update
We are continuing to work with our carrier partner to investigate the SMS Delivery Delays to Liberia Orange. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Jun 05, 2021 - 07:11 PDT
Update
We are continuing to work with our carrier partner to investigate the SMS Delivery Delays to Liberia Orange. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Jun 05, 2021 - 05:19 PDT
Investigating
We are experiencing SMS delivery delays when sending messages to Liberia Orange. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Jun 05, 2021 - 03:18 PDT
This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).