Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Delays to UK Numbers
Incident Report for Twilio
Resolved
We are now seeing full recovery, this incident has been resolved.
Posted Oct 12, 2020 - 06:06 PDT
Monitoring
We are observing recovery in Inbound SMS delivery delays to UK numbers. We will continue monitoring the service, to ensure a full recovery. We will provide another update in 30 minutes or as soon as more information becomes available.
Posted Oct 12, 2020 - 05:25 PDT
Update
We are continuing to experience issues with Inbound SMS delivery delays to UK numbers. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available
Posted Oct 12, 2020 - 03:42 PDT
Investigating
We are experiencing Outbound and Inbound SMS delivery delays to a small subset Twilio customer the UK . Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Oct 12, 2020 - 02:33 PDT
This incident affected: CARRIER NETWORK (SMS, Europe, SMS Delivery Notifications & Status Callbacks).