The issue preventing WhatsApp phone number from being displayed for senders created via the Senders API has been resolved and the service is operating normally at this time.
Posted Mar 05, 2026 - 14:42 PST
Monitoring
We are observing a recovery in the display of WhatsApp phone number for senders created via the Senders API. We will be monitoring the service to ensure a full recovery and provide another update in 30 minutes or as soon as more information becomes available.
Posted Mar 05, 2026 - 14:03 PST
Update
We continue to experience WhatsApp phone number not displayed for senders created via senders API. Our team is actively investigating this issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Mar 05, 2026 - 11:49 PST
Update
Twilio customers may be experiencing WhatsApp phone number not displayed for senders created via senders API. Our team is actively investigating this issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Mar 05, 2026 - 10:49 PST
Investigating
Our monitoring systems have detected a potential issue with WhatsApp phone number not displayed for senders created via senders API. Our engineers have been alerted and are investigating. We will provide an update when we have more details.
Posted Mar 05, 2026 - 10:35 PST
This incident affected: PROGRAMMABLE MESSAGING (Messaging Channels).